Resolved - some candidates not able to submit forms

Incident Report for Talent Funnel

Resolved

This incident has been resolved.
Posted Oct 06, 2025 - 14:21 BST

Monitoring

We've had notifications of some candidates not being able to complete forms on Sunday. This has already been resolved and all existing links in sent emails and SMS'es should work as expected. There is no need to resend any emails to candidates. We'll keep monitoring as well.
Posted Oct 06, 2025 - 09:53 BST
This incident affected: Forms.