Funnel Count / Candidate Navigation

Incident Report for Talent Funnel

Resolved

This incident has been resolved.
Posted Feb 10, 2026 - 11:24 GMT

Investigating

We've had some reports on funnel count and candidate navigation issues - we're just releasing an improvement which should be live in next 30 mins
Posted Feb 10, 2026 - 11:00 GMT
This incident affected: ATS.